Задание 22. Анализ программы с циклами и ветвлениями

Задачи для тренировки

Задача №1

Ниже на четырёх языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: L и M. Укажите наибольшее число x, при вводе которого алгоритм печатает сначала 4, а потом 5.

С++ Python

#include   
using namespace std;
int main()

{
   int x, L, M, Q;
   cin >> x;
  Q = 9;
  L = 0;
  while (x >= Q) {
     L = L + 1;
     x = x - Q;
  }
  M = x;
  if (M < L) {
    M = L;
     L = x;
  }
  cout <
  return 0;
}

x = int(input())
Q = 9
L = 0
while x >= Q:
    L = L + 1
    x = x - Q
M = x
if M < L:
    M = L
    L = x
print(L)
print(M)
Алгоритмический язык Паскаль

алг
нач
   цел x, L, M, Q
   ввод x
   Q := 9
   L := 0
   нц пока x >= Q
     L := L + 1
     x := x - Q
   кц
   M := x
   если M < L
     то
       M := L
       L := x
   все
   вывод L, нс, M
кон

var x, L, M, Q: integer;
begin
   readln(x);
   Q := 9;
   L := 0;
   while x >= Q do
   begin
     L := L + 1;
     x := x - Q;
   end;
   M := x;
   if M < L then
   begin
     M := L;
     L := x;
   end;
   writeln(L);
   writeln(M);
end.