Задача #1728

Условие

Запишите число, ко­то­рое будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния сле­ду­ю­щей программы. Для Ва­ше­го удоб­ства про­грам­ма пред­став­ле­на на пяти язы­ках программирования.

 

Бейсик Python
DIM N, S AS INTEGER
N = 0
S = 260
WHILE S > 0
    S = S - 15
    N = N + 2
WEND
PRINT N
n = 0
s = 260
while s > 0:
    s = s - 15
    n = n + 2
print(n)
Паскаль Алгоритмический язык
var n, s: integer;
begin
    n := 0;
    s := 260;
    while s > 0 do
    begin
        s := s - 15;
        n := n + 2;
    end;
    writeln(n);
end.
алг
нач
    цел n, s
    n := 0
    s := 260
    нц пока s > 0
        s := s - 15
        n := n + 2
    кц
    вывод n
кон
Си++
#include  
using namespace std;
int main() {
    int n, s;
    n = 0, s = 260;
    while (s > 0) {
        s = s - 15;
        n = n + 2;
    }
    count << n << endl;
    return 0;
}

Правильный ответ: 36

Для просмотра решения необходимо авторизоваться.

Комментарии

Для добавления комментариев необходимо авторизоваться.